DISCUSSIONS

Find the answers to many of your expat questions here

View Latest Posts

You're missing out...

As a member you can enjoy exclusive info and offers.

REGISTER NOW

Google Chrome

Posted by PamandAndrew-390752 - Created: 3 years ago
0 0
Sorry no image available

3 replies (Showing replies: 1 to 3)

Sorry no image available
Posted by PamandAndrew-390752 - 3 years ago

Hello and thanks for the advice. I seem to have 'cured' it but not too sure how! Reset everything and it is now coming up with google.com in English...I don't know why it went to Italy, I don't recall doing anything different but have no idea, to be honest...probably remain a mystery, to me anyway!

Sorry no image available
Posted by demonhighwayman - 3 years ago

Sounds like a browser hijack, have you installed anything new lately (including non windows updates) ? If not "moi's" suggestion is good info.

Sorry no image available
Posted by moi-383589 - 3 years ago

If you don't get a fix-go to chrome settings, scroll to 'People', tick 'enable guest browsing' 'let anyone add a person to chrome' and sign in as another person.Make a shortcut to your desktop and away you go.