DISCUSSIONS

Find the answers to many of your expat questions here

View Latest Posts

You're missing out...

As a member you can enjoy exclusive info and offers.

REGISTER NOW

problem with tablet.

Posted by tigre-979768 - Created: 3 years ago
0 0
Sorry no image available

4 replies (Showing replies: 1 to 4)

Sorry no image available
Posted by ltinerant ChiId - 3 years ago

I worked in the IT Industry for 12 years until the early 2000's and can honestly say that 99.9% of all computer problems boil down to user error.

Sorry no image available
Posted by tigre-979768 - 3 years ago

Thanks for your replies. I have now solved the problem, don't ask me how, just kept fiddling around so to speak. I must say I have had mine for over a year now with no problems apart from this one, which no doubt was my fault.

Sorry no image available
Posted by risuda - 3 years ago

We also had an mpman tablet. It worked fine for 4 months then wouldn't load up. I took it back to the shop, they sent it off for repair. 2 weeks later I got it back. This happened 4 times and eventually the shop had to give me my money back ( in a voucher that I could spend on anything in any of their branches). Needless to say we would never purchase  another mpman tablet

Sorry no image available
Posted by jibble - 3 years ago

I also had an MPMAN tablet, when mine started to play up, I took it back to the

shop where it had been purchased and they sent it away. This was still under guarantee

but could not be repaired. I was given a voucher to buy a new one, needless to say I did not get the MPMAN again, have now got the gigaset tablet and is working beautifully.

 

Good luck